Unity 6.3
0 онлайн 42 гостей 3 в системе
Вход

Включить глобальное освещение Enlighten в реальном времени

Чтобы включить глобальное освещение Enlighten Realtime в вашем Scene, открыть Освещение окна (меню: Окно > Рендеринг > Освещение) и разрешить Глобальное освещение в реальном времени.

Чтобы отключить эффект Реальное время GI на конкретном Свете, выберите Свет GameObject и, в компоненте Light, установите Косвенный множитель Это означает, что Свет не вносит никакого косвенного света в пространство, Scene.

Чтобы полностью отключить Реальное время GI, откройте окно Освещения (меню: Окно > Рендеринг > Освещение) и снимите флажок Глобальное освещение в реальном времени.

Подробные пошаговые инструкции по использованию Enlighten Realtime Global Illumination см. в учебнике Unity по Precomputed Realtime GI.

Световые зонды и Enlighten глобальное освещение в реальном времени

Примечание: Световые зонды вести себя по-другому, когда вы включаете Enlighten Realtime Global Illumination.

Чтобы реагировать на изменения во время выполнения в освещении Scene, они итеративно пробирают освещение во время выполнения.

Когда вы отключаете Enlighten Realtime Global Illumination в Scene, Light Probes используют только запеченные данные освещения. Это означает, что они не реагируют на изменения времени выполнения в освещении Scene.

Глобальное освещение в режиме реального времени

Если источник света ещё и отбрасывает тени, Unity отрисовывает в его карту теней как динамические, так и статические GameObject сцены — карта тени. Шейдеры материалов и статических, и динамических GameObject считывают эту карту теней, благодаря чему такие объекты отбрасывают тени друг на друга в реальном времени. Расстояние тени настройка определяет максимальное расстояние, на котором тени начинают выпадать и исчезают полностью, что в свою очередь влияет на производительность и качество изображения.

Результаты Enlighten Realtime Global Illumination также включают мягкие тени, если только Scene не очень маленький. Эти тени обычно более крупнозернистые, чем то, что может достичь lightmapping.

Чтобы изменить настройки Расстояние тени, перейдите в Изменить > Project Настройки > Качество > Тени.