Сбор данных о производительности на целевой платформе
Запись данных о производительности с помощью Unity Profiler на целевой платформе.
Вы можете записывать производительность вашего приложения на выбранной платформе выпуска, чтобы обнаружить реалистичные показатели производительности о вашем приложении. Profiler может подключаться к вашему приложению, когда оно работает на целевом устройстве следующими способами:
- Через локальную сеть
- Прямо через кабель
- Через IP адрес
Примечание: Профильирование на веб-платформе имеет другой рабочий процесс. Для профилирования веб-сборок см. Профильирование веб-компиляции.
Подключите приложение к Profiler
Для подключения приложения к Profiler:
- Откройте Создание профилей окно (меню: Файл > Создать профили)
- Выберите целевую платформу приложения
- Включите параметр Разработанная сборка
- Дополнительно включите параметр Autoconnect Profiler для автоматического подключения к Profiler
- Опционально включите Поддержка глубокого профилирования для использования Глубокое профилирование
- Выбрать Создание и запуск, и убедитесь, что приложение работает на вашем целевом устройстве.
- Откройте окно Profiler (меню: Окно > Анализ > Profiler). Если вы включили параметр Автоподключение Profiler, Profiler автоматически собирает данные.
- Если параметр Autoconnect Profiler отключен, Выберите раскрывающееся меню Выбор цели рядом с значком Запись () и выберите из списка целевой проигрыватель.
- Выберите значок записи
Если включена настройка Autoconnect Profiler, Profiler собирает данные, как только вы открываете окно Profiler, пока ваше приложение работает. В противном случае окно Profiler собирает данные, когда вы выбираете цель из раскрывающегося списка Выбор цели и выбираете Запись.
Подключение к приложению через адрес IP
Для подключения через адрес IP:
- Откройте окно Profiler (меню: Окно > Анализ > Profiler)
- Выберите раскрывающееся меню Выбор цели рядом с значком записи ()
- Выберите <Введите IP> в раскрывающемся списке.
- Введите адрес IP в диалоге, который появится, и, по желанию, порт плеера, к которому вы хотите подключиться.
- Выберите значок записи
Непрерывный сбор данных
Чтобы непрерывно собирать данные во время выполнения приложения:
- Откройте Настройки проигрывателя (меню: Изменить > Project Настройки > Проигрыватель)
- В разделе Разрешение и презентация включите Запуск в фоновом режиме