Unity 6.3
0 онлайн 85 гостей 3 в системе
Вход

Настройка параметров с помощью профилей сборки

Настройте конкретные параметры проекта для каждого профиля сборки, чтобы создать уникальные конфигурации для ваших целевых платформ.

Примечание: Переопределения профиля сборки используются в режиме воспроизведения и в Unity проигрывателе.

См. следующие разделы для добавления параметров и управления ими с помощью Добавление параметров, включая сведения о переопределении Диагностика и Настройки качества.

Добавление настраиваемых параметров

Используйте кнопку Добавить параметры, чтобы добавить дополнительные параметры в профиль сборки, а затем настроить их по мере необходимости. Список параметров, которые можно добавить, см. в Справка по окну профилей сборки.

Чтобы добавить параметры в профиль сборки, выполните следующие действия.

  1. В окне Профили сборки выберите или создайте профиль сборки для целевой платформы.
  2. Выберите Добавить настройки.
  3. В раскрывающемся списке выберите параметры, которые нужно добавить.

Добавленные параметры отображаются в разделе с раскрывающимся меню, где их можно настроить для профиля сборки.

Удаление или сброс параметров

Чтобы удалить или сбросить параметры в добавленном разделе, выполните следующие действия.

  1. Откройте меню Больше (и) добавленного раздела.

  2. Выберите один из следующих параметров:

    Свойство Описание
    Сброс Сбросьте значения параметров в разделе до глобальных значений для целевой платформы. Установите глобальные значения из Изменить > Project Настройки.
    Удалить Удалите раздел из окна Создание профилей. Чтобы настроить параметры снова, добавьте раздел обратно с помощью Добавить параметры.

Переопределение диагностических данных

Раздел Диагностика всегда видим для поддерживаемых профилей сборки и не добавляется через Добавить параметры.

Чтобы переопределить стандартный Диагностика учрежденных в соответствии Project Настройки, выполните следующие действия:

  1. Перейдите в Файл > Профиль сборки.
  2. Выберите или создайте профиль сборки для целевой платформы.
  3. Под Диагностика, выберите необходимую опцию из списка Диагностические данные Для получения более подробной информации, см. Справочная информация об окне построения профилей.

Ваш профиль сборки теперь использует назначенное значение и переопределяет Project Настройки. Чтобы вернуть значение из Project Настройки, установите Диагностические данные на Использование Project Настройки → Диагностика.

Переопределение параметров качества

При добавлении раздела Настройки качества с помощью кнопки Добавить настройки уровни качества для профиля сборки отображаются в развертываемом окне Настройки качества.

Список доступных уровней качества в разделе Настройки качества окна Профили построения.
Список доступных уровней качества в разделе Настройки качества окна Профили построения.

Список наследует уровни качества для вашей целевой платформы от глобальных уровней Качество, расположенных в Изменить > Project Настройки > Качество.

Примечание: В режиме воспроизведения используется уровень качества, выбранный в глобальных настройках качества.

Чтобы добавить новый уровень качества в профиль сборки, выполните следующие действия:

  1. Добавить новый уровень качества к глобальным настройкам качества в Изменить > Project Настройки > Качество.
  2. В окне Создание профилей выберите Добавить (+) в нижней части списка уровней качества.
  3. Чтобы установить добавленный уровень качества по умолчанию, щелкните правой кнопкой мыши (macOS: Ctrl+ щелчок) любой уровень качества.

Примечание: Переименование или удаление уровня качества в глобальных настройках качества обновляет любой профиль сборки, содержащий этот уровень.

Дополнительные ресурсы